Задать вопрос
28 февраля, 23:41

задано натуральное число N, вычислите сумму цифр числа используя цикл while

+1
Ответы (1)
  1. 1 марта, 01:56
    0
    var sum, n:int64;

    begin

    write ('Vvedite chislo: ') ;

    readln (n) ;

    while (n>0) do begin

    sum:=sum + (n mod 10) ;

    n:=n div 10;

    end;

    writeln (sum) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «задано натуральное число N, вычислите сумму цифр числа используя цикл while ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Сколько раз будет выполнен этот цикл? i:=2; while i
Ответы (2)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
1. Ввести целое число и найти сумму его цифр. Пример Введите целое число 1234 Сумма цифр числа 1234 равна 10 2. Вычислить в Паскале степень числа, используя цикл while
Ответы (1)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)