Задать вопрос
23 марта, 03:10

1. Ввести целое число и найти сумму его цифр.

Пример

Введите целое число 1234

Сумма цифр числа 1234 равна 10

2. Вычислить в Паскале степень числа, используя цикл while

+4
Ответы (1)
  1. 23 марта, 04:44
    0
    Var

    a, Summ:integer;

    begin

    write ('Введите число ') ;

    readln (a) ;

    Summ : = 0;

    while a > 0 do

    begin

    Summ : = Summ + a mod 10;

    a : = a div 10;

    end;

    writeln ('Сумма цифр равна ', Summ) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Ввести целое число и найти сумму его цифр. Пример Введите целое число 1234 Сумма цифр числа 1234 равна 10 2. Вычислить в Паскале степень ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести целое число и определить, верно ли, что в нём ровно 3 цифры. Нужно с помощью цикла "while" Пример: Введите число: 123 Да Пример: Введите число: 1234 Нет.
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
Ввести целое число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. Пример: Введите целое число: Введите целое число: 1232 1224 Нет. Да. Через ветвление, while, repeat, until
Ответы (1)
Задание 1. Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе. Пример: Введите номер месяца: -2 Введите номер месяца: 11 В этом месяце 30 дней. Вы вводили неверно 1 раз. Задание 2.
Ответы (1)
Ввести целое число и найти сумму его цифр. Пример: Введите целое число: 1 2 3 4 Сумма цифр числа 1 2 3 4 равна 10
Ответы (2)