Задать вопрос
17 января, 11:08

1. Напечатайте индексы всех равных элементов произвольного массива A (N; N). 2. В заданном тексте заменить последовательность символов X (I) на A (I), подсчитать количество произведенных замен. эти две задачи необходимо решить в турбо паскале

+1
Ответы (1)
  1. 17 января, 14:07
    0
    1.

    const nn=50;

    var

    a:array [1 ... nn, 1 ... nn] of integer;

    i, j, k, l, n:integer;

    begin

    writeln ('N = ') ;

    readln (n) ;

    for i:=1 to n do

    for j: = 1 to n do

    readln (a[i, j]) ;

    writeln;

    writeln ('Сформированный массив:') ;

    for i:=1 to n do

    begin

    for j: = 1 to n do

    write (a[i, j],' ') ;

    writeln;

    end;

    writeln;

    writeln ('Индексы равных элементов:') ;

    for i:=1 to n do

    for j: = 1 to n do

    for k:=i+1 to n do

    for l: = j to n do

    if (a[i, j] = a[k, l]) then writeln ('[', i,',', j,'] = [', k,',', l,']') ;

    end.

    2. Недостаточно данных для решения задачи.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Напечатайте индексы всех равных элементов произвольного массива A (N; N). 2. В заданном тексте заменить последовательность символов X ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Дан целочисленный массив из 7 элементов: 1) подсчитать произведение элементов массива кратных 5 и кратных 3. 2) подсчитать среднее значение четных элементов массива.
Ответы (1)