Задать вопрос
17 января, 12:19

Найти среднее значение целых десятичных чисел кол-во задается с клавиатуры

Писать на языке паскаль

+3
Ответы (2)
  1. 17 января, 14:23
    0
    Var i, n, m, sum:integer; r:real;

    Begin

    Randomize;

    write ('Введите количество целых десятичных чисел') ;

    Readln (n) ;

    for i:=1 to n do begin

    m:=random (100) - 50;

    write (m:4) ; sum: = sum + m; end;

    writeln;

    r: = sum/n; write ('среднее значение ', n,' целых десятичных чисел ', r:8:4) ; end.
  2. 17 января, 15:21
    0
    Var col, col1, sum, zn: integer;

    srar: real;

    Begin

    readln (col) ;

    col1:=col;

    sum:=0;

    while col1 > 0 do

    begin

    readln (zn) ;

    sum:=sum+zn;

    col1:=col1-1;

    end;

    srar:=sum/col;

    writeln (srar) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти среднее значение целых десятичных чисел кол-во задается с клавиатуры Писать на языке паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Составьте программу на языке Паскаль для следующих задач: 1. Найдите сумму всех чисел от a до 500 (значение a вводится с клавиатуры; a≤500). 2. Найдите среднее арифметическое всех целых чисел от a до b (значение a и b вводится с клавиатуры; a≤b). 3.
Ответы (1)
Найти: а) сумму всех целых чисел от 100 до 500; б) сумму всех целых чисел от a до 500 (значение a вводится с клавиатуры; a 500) ; в) сумму всех целых чисел от - 10 до b (значение b вводится с клавиатуры; b - 10) ;
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Паскаль 5.3 Напечатать "столбиком": а) все целые числа от 20 до 35 б) квадраты всех целых чисел от a до 50 (значение a вводится с клавиатуры; b>=10) в) третьи степени всех целых чисел от a до 50 (значение a вводится с клавиатуры; a
Ответы (1)