Задать вопрос
27 октября, 04:22

Дан массив А (к). Из элементов массива А сформировать массив В таким образом: сначала поместить все отрицательные массивы элемента А, потом равные нулю, а положительные в конце.

+3
Ответы (2)
  1. 27 октября, 05:28
    0
    В простом варианте:

    const nn=50;

    var

    i, n, j:integer;

    a, b:array [1 ... nn] of integer;

    begin

    write ('Введите количество элементов массива: ') ;

    readln (n) ;

    for i:=1 to n do readln (a[i]) ;

    j:=1;

    for i:=1 to n do if a[i]<0 then begin b[j]:=a[i]; j:=j+1; end;

    for i:=1 to n do if a[i]=0 then begin b[j]:=a[i]; j:=j+1; end;

    for i:=1 to n do if a[i]>0 then begin b[j]:=a[i]; j:=j+1; end;

    for i:=1 to n do write (b[i],' ') ;

    end.
  2. 27 октября, 07:09
    0
    Program main;

    Var A, B: array [1 ... 100] of integer;

    k, n, i: byte;

    Begin

    i:=1;

    Readln (n) ;

    For k:=1 to n do

    Readln (A[k]) ;

    For k:=1 to n do

    If A[k]<0 then

    Begin

    B[i]:=A[k];

    i:=i+1;

    End;

    For k:=1 to n do

    If A[k]=0 then

    Begin

    B[i]:=A[k];

    i:=i+1;

    End;

    For k:=1 to n do

    If A[k]>0 then

    Begin

    B[i]:=A[k];

    i:=i+1;

    End;

    For i:=1 to n do

    Writeln (B[i]) ;

    Readln;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив А (к). Из элементов массива А сформировать массив В таким образом: сначала поместить все отрицательные массивы элемента А, потом ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Сформировать массив А из 30 случайных целых чисел в диапазоне от-30 да 50. Сформировать массивы С, В которые содержат: массив В - четные элементы из массива А в порядке их следования в массиве А, массив С - отрицательные элементы массива А в
Ответы (1)
Массив заполнен случайным образом 20 числами в интервале от 0 до 100. 1) найти максимальный и минимальный элемент массива, а так же их сумму 2) найти среднее арифметическое элементов массива 3) из элементов массива сформировать два массива с четными
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)