Задать вопрос
24 декабря, 08:51

Напишите программу на языке программирования (или составьте алгоритм). Дано натуральное число n. Определите, сколько раз цифра "7" встречается в записи данного числа.

+2
Ответы (1)
  1. 24 декабря, 12:01
    0
    var

    a, b, k:integer;

    begin

    write ('Введите число: ') ;

    readln (a) ;

    k:=0;

    while a0 do

    begin

    b: = a mod 10;

    a: = a div 10;

    if b=7 then k:=k+1;

    end;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу на языке программирования (или составьте алгоритм). Дано натуральное число n. Определите, сколько раз цифра "7" ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
Ниже на пяти языках программирования записан алгоритм. Получив на вход натуральное число x, этот алгоритм печатает число R. Укажите такое число x, при вводе которого алгоритм печатает двузначное число, сумма цифр которого равна 13.
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
Напишите как решать Ниже на 5 языках программирования записан алгоритм. Получив на вход число х, этот алгоритм печатает число l. Укажите наибольшее нечетное число х, при вводе которого алгоритм печатает 102.
Ответы (1)
Придумайте натуральное число которое удовлетворяет следущим условиям: 1. Запись числа состоит из 7 цифр 2. Сумма всех цифр числа равна 39. 3. В записи числа есть хотя бы одна цифра 4 4. В записи числа есть хотя бы одна цифра 7 5.
Ответы (1)