Задать вопрос
29 августа, 20:16

1. Среди трехзначных чисел сколько таких, что сумма крайних в три раза больше средней цифры.

2. Среди трехзначных чисел сколько таких, что все цифры разные

+3
Ответы (1)
  1. 29 августа, 21:37
    0
    1) program z1;

    uses crt;

    var a, b, c, d, e, f, k, i: integer;

    begin

    for i:=100 to 999 do begin

    a:=i div 100;

    b:=i mod 100 div 10;

    c:=i mod 100 mod 10;

    d:=a+c;

    e:=3*c;

    if d>e then innc (k) ;

    end;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Среди трехзначных чисел сколько таких, что сумма крайних в три раза больше средней цифры. 2. Среди трехзначных чисел сколько таких, что ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Среди всех трёхзначных чисел (отрицательных и положительных) найти и выписать на экран те, у которых произведение крайних цифр совпадает с кубом средней цифры.
Ответы (1)
Информатика (Pascal) : Составить программу для решения следующей задачи: Среди всех положительных трёхзначных чисел найти и выписать на экран те, у которых сумма крайних цифр совпадает с утроенной средней цифрой.
Ответы (1)
Действие компьютерного вируса состоит в том, что вместо букв "б", "в", "л", "о", "т" печатаются цифры, причём разным буквам соответствуют разные цифры кроме цифры 0 причем разным буквам соответствуют разные цифры.
Ответы (1)
На столе стоят три вазы с конфетами. В левой вазе лежат A конфет, в средней вообще лежат B конфет, в правой вазе лежат C конфет.
Ответы (1)
Автомат получает на вход два трехзначных числа. По этим числам строится новое число по следующим правилам. Вычисляются три числа - сумма старших разрядов заданных трехзначных чисел, сумма средних разрядов этих чисел, сумма младших разрядов.
Ответы (1)