Задать вопрос
5 января, 15:33

Среди всех трёхзначных чисел (отрицательных и положительных) найти и выписать на экран те, у которых произведение крайних цифр совпадает с кубом средней цифры.

+3
Ответы (1)
  1. 5 января, 17:04
    0
    Var i, c:integer;

    begin

    for i:=100 to 999 do

    begin

    c:=i div 10 mod 10;

    if (i div 100) * (i mod 10) = c*c*c then writeln (-i,' ', i) ;

    end;

    end.

    Результат:

    -100 100

    -111 111

    -128 128

    -200 200

    -224 224

    -300 300

    -339 339

    -400 400

    -422 422

    -500 500

    -600 600

    -700 700

    -800 800

    -821 821

    -848 848

    -900 900

    -933 933
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Среди всех трёхзначных чисел (отрицательных и положительных) найти и выписать на экран те, у которых произведение крайних цифр совпадает с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Информатика (Pascal) : Составить программу для решения следующей задачи: Среди всех положительных трёхзначных чисел найти и выписать на экран те, у которых сумма крайних цифр совпадает с утроенной средней цифрой.
Ответы (1)
1. Среди трехзначных чисел сколько таких, что сумма крайних в три раза больше средней цифры. 2. Среди трехзначных чисел сколько таких, что все цифры разные
Ответы (1)
Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел.
Ответы (1)
Дано массив с N положительных и отрицательных чисел. а) найти среднее аримфметичкое отдельно для положительных, среднее геометрическое - для негативных. б) найти максимальную по длинне последовательность чисел с одинаковым знаком.
Ответы (1)
Среди всех трёхзначных положительных чисел найти количество тех, у которых сумма цифр является чётным числом. На экран вывести как сами найденные числа, так и их количество.
Ответы (1)