Задать вопрос
6 января, 15:18

Найти в одномерном массиве А10 количество положительных элементов, кратных трём. Написать программу на языке Паскаль.

+3
Ответы (1)
  1. 6 января, 17:49
    0
    var A:array[1 ... 10] of integer;

    i, k:integer;

    begin

    k:=0;

    for i:=1 to 10 do

    if (a[i]>0) and (a[i] mod 3=0) then k:=k+1;

    writeln ('k=', k) ;

    readln;

    end.

    помоему так)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти в одномерном массиве А10 количество положительных элементов, кратных трём. Написать программу на языке Паскаль. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)
Задачи на массивы (в паскале) : 1. Найти количество нулей в одномерном массиве. 2. найти сумму элементов кратных 5. 3. найти сумму первых 5 элементов. 4. верно ли что в массиве есть два нуля. 5. найти сумму элементов из промежутка от А до В.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Прошу, помогите написать программу! (Тема - Операции над массивами.) Написать программу, которая в одномерном массиве, заданным вводом данных с клавиатуры находит число положительных чисел в массиве.
Ответы (1)
написать программу на паскале: в целочисленном одномерном массиве из N (N
Ответы (1)