Задать вопрос
29 января, 01:53

Дан массив вещественных чисел:

Все элементы с нечетными номерами заменить на их квадратный корень

+4
Ответы (1)
  1. 29 января, 04:40
    0
    var

    a:array[1 ... 100] of real;

    i, n:integer;

    begin

    write ('Введите количество элементов ') ; readln (n) ;

    for i : = 1 to n do

    begin

    write ('a[', i,'] = ') ;

    readln (a[i]) ;

    end;

    writeln;

    writeln ('Исходный массив:') ;

    for i : = 1 to n do

    begin

    write (a[i], ' ') ;

    if i mod 2 = 1 then

    a[i] : = sqrt (a[i]) ;

    end;

    writeln;

    writeln;

    writeln ('Преобразованный массив:') ;

    for i : = 1 to n do

    write (a[i]:0:2, ' ') ;

    writeln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив вещественных чисел: Все элементы с нечетными номерами заменить на их квадратный корень ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Нужна помощь! 1. дан массив состоящий из 5 случайных целых чисел от - 1 до 10. Все его элементы уменьшить на число 20. 2. дан массив состоящий из 8 вещественных чисел. все элементы с четными номерами уменьшить на 1, с нечетными-увеличить на 1.
Ответы (1)
Сделайте в паскаль. Дан массив вещественных чисел. Вывести на экран новое состояние массива, в котором: a) Каждый отрицательный элемент заменить на его абсолютную величину; b) Все элементы с нечетными номерами заменить на их квадратный корень;
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1). Дан массив из n чисел (n четное). Написать программу миняющую местами элементы с четными и нечетными номерами 2). Дан массив из n чисел.
Ответы (1)
Паскаль Дан массив вещественных чисел. а) Каждый элемент, больший 10, заменить его квадратным корнем. б) Все элементы массива с четными номерами заменить их абсолютной величиной.
Ответы (1)