Задать вопрос
26 февраля, 09:12

1). Дан массив из n чисел (n четное). Написать программу миняющую местами элементы с четными и нечетными номерами

2). Дан массив из n чисел. Написать программу циклически сдвигающую элементы массива на 1 позицию вправо (7,8,9,10,15,14; 14,7,8,9,10,15)

+3
Ответы (1)
  1. 26 февраля, 11:39
    0
    1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 const nmax = 20; var A : array [1 ... nmax] of integer; i, n, temp : integer; begin Randomize; Repeat Write ('Размер массива: ') ; Readln (n) ; until n in [1 ... nmax]; Writeln ('Исходный массив: ') ; for i : = 1 to n do begin A[i] : = random (30) ; Write (A[i], ' ') ; end; Writeln; Writeln ('Массив после изменений: ') ; temp : = a[n]; for i : = n downto 2 do a[i] : = a[i - 1]; a[1] : = temp; for i : = 1 to n do Write (A[i], ' ') ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1). Дан массив из n чисел (n четное). Написать программу миняющую местами элементы с четными и нечетными номерами 2). Дан массив из n ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данных Сначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)