Задать вопрос
29 апреля, 12:37

Паскаль

Дан массив вещественных чисел.

а) Каждый элемент, больший 10, заменить его квадратным корнем.

б) Все элементы массива с четными номерами заменить их абсолютной величиной.

+4
Ответы (1)
  1. 29 апреля, 13:13
    0
    A.

    var

    a:array[1 ... 10] of real;

    i:integer;

    begin

    for i: = 1 to 10 do Begin

    write ('Введите ', i,'-ый элемент массива ') ;

    Readln (a[i]) ;

    if a[i]>10 then a[i]:=sqrt (a[i]) ;

    End;

    write ('Преобразованный массив ') ;

    for i : = 1 to 10 do write (a[i],' | ') ;

    end.

    б.

    var

    a:array[1 ... 10] of real;

    i:integer;

    begin

    for i: = 1 to 10 do Begin

    write ('Введите ', i,'-ый элемент массива ') ;

    Readln (a[i]) ;

    if (i mod 2) = 0 then a[i]:=trunc (a[i]) ;

    End;

    write ('Преобразованный массив ') ;

    for i : = 1 to 10 do write (a[i],' | ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль Дан массив вещественных чисел. а) Каждый элемент, больший 10, заменить его квадратным корнем. б) Все элементы массива с четными ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Сделайте в паскаль. Дан массив вещественных чисел. Вывести на экран новое состояние массива, в котором: a) Каждый отрицательный элемент заменить на его абсолютную величину; b) Все элементы с нечетными номерами заменить на их квадратный корень;
Ответы (1)
Нужна помощь! 1. дан массив состоящий из 5 случайных целых чисел от - 1 до 10. Все его элементы уменьшить на число 20. 2. дан массив состоящий из 8 вещественных чисел. все элементы с четными номерами уменьшить на 1, с нечетными-увеличить на 1.
Ответы (1)
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данных Сначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)