Задать вопрос
1 декабря, 17:31

В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите номер дня, на который пробег спортсмена составит не менее y километров. Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.

+4
Ответы (2)
  1. 1 декабря, 18:13
    0
    var

    x, y:real;

    day:integer;

    begin

    readln (x) ;

    readln (y) ;

    day : = 1;

    while x < y do

    begin

    x : = x * 1.1;

    day : = day + 1;

    end;

    writeln (day) ;

    end.
  2. 1 декабря, 20:08
    0
    var

    x, y:real;

    n:integer;

    begin

    readln (x) ;

    readln (y) ;

    while x
    x:=x*0.1+x;

    n:=n+1;

    end;

    writeln ('den=', n)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
В Python С клавиатуры вводится натуральное число. Программа должна вывести следующее за ним четное число. Например, если ввести 7, то программа должна вывести 8, а если ввести 8, то программа должна вывести 10.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
Разделите точками цифры этого числа группами по три, начиная справа. Программа получает на вход натуральное число, содержащее не более 100 цифр. Программа должна вывести то же число, с точками между некоторыми цифрами этого числа.
Ответы (1)