Задать вопрос
16 июня, 10:19

Написать программу вычисления среднего арифметическое трех чисел с клавиатуры результат вывести с четырьмя знаками после запятой

+5
Ответы (1)
  1. 16 июня, 11:17
    0
    Pascal:

    var a, b, c:real;

    begin

    write ('Number 1: ') ;

    readln (a) ;

    write ('Number 2: ') ;

    readln (b) ;

    write ('Number 3: ') ;

    readln (c) ;

    writeln ('Srednee: ', (a+b+c) / 3:0:4) ;

    readln;

    end.

    C++:

    #include

    #include

    using namespace std;

    int main ()

    {

    float a, b, c;

    cout. setf (std::ios_base::fixed, std::ios_base::floatfield) ;

    cout <<"Number 1: ";

    cin >>a;

    cout <<"Number 2: ";

    cin >>b;

    cout <<"Number 3: ";

    cin >>c; cout. precision (4) ;

    cout <<"Srednee: " << (a+b+c) / 3 <
    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу вычисления среднего арифметическое трех чисел с клавиатуры результат вывести с четырьмя знаками после запятой ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
1 Написать процедуру вычисления среднего арифметического двух чисел. Числа и результат передаются в качестве параметров , в каком из двух введенных с клавиатуры целых чисел произведение цифр больше.
Ответы (1)
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)