Задать вопрос
18 декабря, 23:27

Паскаль! Дан массив из 20 действительных чисел, определить среднее арифметическое элементов с четными индаксами и среднее арифметическое с нечетными индаксами

+4
Ответы (1)
  1. 19 декабря, 02:53
    0
    Var a: array [1 ... 20] of integer; i, s1, s2:integer;

    Begin

    For i:=1 to 20 do begin

    Writeln ('введите элемент ', i) ; read (a[i]) ;

    If i mod 2=0 then s1:=s1+a[i] else

    s2:=s2+a[i];

    end;

    Writeln ('Среднее ариф. четных ', s1/20,'; А нечетных ', s2/20) ;

    readln;

    end.

    Ну как всегда: вопросы - в личку)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль! Дан массив из 20 действительных чисел, определить среднее арифметическое элементов с четными индаксами и среднее арифметическое с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)
Помогите решить через паскаль 1) массив А вводится с клавиатуры, найти среднее арифметическое его элементов с нечетными номерами, размер произвольный.
Ответы (1)