Задать вопрос
19 июня, 19:09

составить программу для: подсччета всех значений функции y=x^2-2x на отрезке [-2; 2] с шагом h=0.5

и блоксхему

+5
Ответы (1)
  1. 19 июня, 22:34
    0
    Var y, x:real;

    begin

    x:=-2;

    while x < = 2 do begin

    y:=sqr (x) - 2x; {Считаем значение функции}

    writeln (y) ; {Выводим значение функции}

    x:=x+0.5; {Наш шаг цикла}

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составить программу для: подсччета всех значений функции y=x^2-2x на отрезке [-2; 2] с шагом h=0.5 и блоксхему ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. найти функцию y=4x-5 на отрезке [1; 30] с шагом h=3. 2. Найти функцию y=5x²-2x+1 на отрезке [-5; 5] с шагом h=2. Сделать в Паскале.
Ответы (1)
Составить программу вычесления значений функции y=x*sin x для значений x. из интервала (-п, п) с шагом 0.3
Ответы (1)
1. Определите сколько раз будет выполняться тело цикла, при вычислении:y=5x+12a на промежутке [-6; 6 ] с шагом 2. 2. Определите сколько раз будет выполняться тело цикла, при вычислении:y=7/12a на промежутке [-2; 1 ] с шагом 0,5. 3.
Ответы (1)
1) Дан массив А (6). Найти минимальный элемент массива и его порядковый номер. 2) Составьте алгоритм и программу вычисления значений функции на произвольном отрезке с произвольным шагом: y = &#61654; x - при - 3 < x < = 3;
Ответы (1)
1. Составить программу табуляции функции f (x) на отрезке [a; b] шагом h. Параметры a, b и h вводит пользователь с клавиатуры. f (x) = x/cosx. 2. Найти значение выражения, используя цикл с параметром.
Ответы (1)