Задать вопрос
3 января, 10:11

1) Дан массив А (6). Найти минимальный элемент массива и его порядковый номер.

2) Составьте алгоритм и программу вычисления значений функции на произвольном отрезке с произвольным шагом:

y =  x - при - 3 < x < = 3;

y = 1 / x2 - в остальных случаях.

+2
Ответы (1)
  1. 3 января, 14:04
    0
    1)

    program t1;

    var

    a: array[1 ... 6] of integer;

    i, m, mi: integer;

    begin

    writeln ('ввод массива') ;

    for i : = 1 to 6 do

    readln (a[i]) ;

    mi : = 1;

    m : = a[mi];

    for i : = 2 to 6 do

    if a[i] < m then

    begin

    mi : = i;

    m : = a[mi];

    end;

    writeln ('минимум: ', m, ' (a[', mi, ']) ') ;

    end.

    2) предполагая, что 'коробочка' - это корень

    program t2;

    const

    F = - 8;

    T = 6;

    S = 2;

    var

    i: real;

    function GetY (x: real) : real;

    begin

    if (x > - 3) and (x < = 3) then

    GetY : = sqrt (x)

    else

    GetY : = 1 / (x * x) ;

    end;

    begin

    writeln ('промежуток [', F, '; ', T, '], шаг ', S, ':') ;

    i : = F;

    while i < = T do

    begin

    writeln ('y (', i, ') = ', GetY (i)) ;

    i : = i + S;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Дан массив А (6). Найти минимальный элемент массива и его порядковый номер. 2) Составьте алгоритм и программу вычисления значений ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан одновременный массив, состоящий из 10 эллементов. Пользователь вводит элементы массива. Ввести массив на экран в строку. Найти минимальный элемент массива.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Что определяет для массива X[1 ... n] следующий алгоритм P: = 0; For k: = 1 to n do If X[k]
Ответы (1)