Задать вопрос
29 сентября, 04:01

Составьте на паскале программу возведения в N-ую степень целого числа X.

+5
Ответы (2)
  1. 29 сентября, 05:58
    0
    Program Multy;

    var i, n, x, mt:integer;

    begin

    write ('введите целое число X ') ;

    readln (x) ;

    write ('введите степень N ') ;

    readln (n) ;

    mt:=x;

    for i:=1 to (n-1) do

    begin

    mt:=mt*x;

    end;

    writeln (x,' в степени ', n,' равно ', mt) ;

    end.
  2. 29 сентября, 06:49
    0
    program power;

    var i, n, x, res:integer;

    begin

    readln (x, n) ;

    res:=x;

    for i:=1 to (n-1) do

    begin

    res:=res*x;

    end;

    writeln (res) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте на паскале программу возведения в N-ую степень целого числа X. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В классическом паскале нет функции возведения в степень. Если программисту на паскале все же потребуется возвести число a>0 в степень n, то с помощью какого выражения он может это сделать?
Ответы (1)
Составьте на Pascal программу возведения в n-ую степень целого числа X
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
В паскале не предусмотрена операция возведения в степень. Составте программу для расчета степени n вещественного числа a (n - натуральное число).
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)