Задать вопрос
1 августа, 23:40

составьте для вычислителя алгоритм, пользуясь которым он запросит последовательность N чисел и сообщит среднее арифметическое.

+4
Ответы (1)
  1. 2 августа, 01:28
    0
    проверь орфографию и если не будет потом работать измени i:=1 на i:=0

    pascal

    var

    n, z, l:integer;

    a:array[1 ... 30] of integer;

    begin

    readln ('kol-vo chisel-', n) ;

    for i:=1 to n do

    begin

    readln (a[i]) ;

    l=l+a[i];

    end;

    z=l/n;

    writeln ('srednee arifm-', z) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составьте для вычислителя алгоритм, пользуясь которым он запросит последовательность N чисел и сообщит среднее арифметическое. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу, которая последовательно запросит 10 целых чисел и в результате сообщит, сколько среди введенных чисел четных и сколько нечетных чисел.
Ответы (1)
Составьте программу по которой компьютер десять раз запросит ввод целых и в результате сообщит сколько среди введённых чисел чётных и сколько нечётных. Паскаль, соответственно.
Ответы (1)
Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел (массив не использовать). Сделайте три варианта программы, используя операторы While, Repeat, For.
Ответы (1)
50+лучший Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел (массив не использовать).
Ответы (2)
Составьте для Система команд исполнителя Вычислитель состоит из двух команд: 1 - прибавить 2 2 - умножить на 3. Вычислителя алгоритм получения из числа 2 числа 30. Алгоритм должен включать только команды 1 и 12, и состоять не более чем из 4 команд.
Ответы (1)