Задать вопрос
4 сентября, 17:58

50+лучший

Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел

(массив не использовать). Сделайте три варианта программы, используя операторы While, Repeat, For.

+4
Ответы (2)
  1. 4 сентября, 19:36
    0
    Var i: integer;

    a, s: real;

    begin

    s:=0;

    writeln ('числа:') ;

    for i:=1 to 10 do

    begin

    write (i,': ') ;

    readln (a) ;

    s:=s+a;

    end;

    writeln ('среднее арифметическое: ', s/10:6:2) ;

    end.
  2. 4 сентября, 20:26
    0
    Через while:

    var

    s, x, i: integer;

    sr: real;

    begin

    s:=0; i:=0;

    while i < 10 do

    begin

    readln (x) ;

    s : = s + x;

    inc (i) ;

    end;

    sr : = s / i;

    writeln (sr) ;

    end.

    Через repeat:

    var

    s, x, i: integer;

    sr: real;

    begin

    s:=0; i:=0;

    repeat

    readln (x) ;

    s : = s + x;

    inc (i) ;

    until i = 10;

    sr : = s / i;

    writeln (sr) ;

    end.

    Через For:

    var

    s, x, i: integer;

    sr: real;

    begin

    s:=0;

    for i:=1 to 10 do

    begin

    readln (x) ;

    s : = s + x;

    end;

    sr : = s / i;

    writeln (sr) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «50+лучший Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел (массив не использовать). Сделайте три варианта программы, используя операторы While, Repeat, For.
Ответы (1)
Составьте программу по которой компьютер десять раз запросит ввод целых и в результате сообщит сколько среди введённых чисел чётных и сколько нечётных. Паскаль, соответственно.
Ответы (1)
1) Какие операторы используются для организации циклов? a) while условие until; b) repeat until условие; c) while условие do; d) repeat do условие.
Ответы (1)
Осуществить ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён 0) и подсчитать их сумму и среднее арифметическое введённых положительных чисел. Использовать оператор repeat.
Ответы (1)
Составьте программу, по которой компьютер 10 раз запросит ввод целого числа и в результате сообщит, сколько среди них оканчивается нулём, а сколько пятью (в Паскале). Как можно скорее!
Ответы (1)