Задать вопрос
11 июля, 07:56

Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел

(массив не использовать). Сделайте три варианта программы, используя операторы While, Repeat, For.

+5
Ответы (1)
  1. 11 июля, 08:20
    0
    Программа может выглядеть так:

    uses Crt;

    const n=10;

    var a, i, Sum: integer;

    Sred: real;

    begin

    ClrScr;

    Sum:=0;

    i:=1;

    While i<=10 do

    begin

    Write ('a = ') ;

    ReadLn (a) ;

    Sum:=Sum+a;

    i:=i+1;

    end;

    Sred:=Sum/n;

    Writeln ('Sred = ', Sred:6:2) ;

    WriteLn;

    Sum:=0;

    i:=1;

    repeat

    Write ('a = ') ;

    ReadLn (a) ;

    Sum:=Sum+a;

    i:=i+1;

    until i>n;

    Sred:=Sum/n;

    Writeln ('Sred = ', Sred:6:2) ;

    WriteLn;

    Sum:=0;

    for i:=1 to n do

    begin

    Write ('a = ') ;

    ReadLn (a) ;

    Sum:=Sum+a;

    end;

    Sred:=Sum/n;

    Writeln ('Sred = ', Sred:6:2) ;

    ReadLn;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
50+лучший Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел (массив не использовать).
Ответы (2)
Составьте программу по которой компьютер десять раз запросит ввод целых и в результате сообщит сколько среди введённых чисел чётных и сколько нечётных. Паскаль, соответственно.
Ответы (1)
Осуществить ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён 0) и подсчитать их сумму и среднее арифметическое введённых положительных чисел. Использовать оператор repeat.
Ответы (1)
1) Какие операторы используются для организации циклов? a) while условие until; b) repeat until условие; c) while условие do; d) repeat do условие.
Ответы (1)
Составьте программу, по которой компьютер 10 раз запросит ввод целого числа и в результате сообщит, сколько среди них оканчивается нулём, а сколько пятью (в Паскале). Как можно скорее!
Ответы (1)