Задать вопрос
22 марта, 12:10

Составьте программу, которая последовательно запросит 10 целых чисел и в результате сообщит, сколько среди введенных чисел четных и сколько нечетных чисел.

+3
Ответы (1)
  1. 22 марта, 13:25
    0
    Var q, w, e, r, t, y, u, i, o, p, l, s, a: Integer;

    begin

    writeln ('Введите 10 целых чисел') ;

    readln (q, w, e, r, t, y, u, i, o, p) ;

    s:=0;

    a:=0;

    for l:=0 to 9 do

    begin

    if l=0 then if q mod 2=0 then s:=s+1 else a:=a+1;

    if l=1 then if w mod 2=0 then s:=s+1 else a:=a+1;

    if l=2 then if e mod 2=0 then s:=s+1 else a:=a+1;

    if l=3 then if r mod 2=0 then s:=s+1 else a:=a+1;

    if l=4 then if t mod 2=0 then s:=s+1 else a:=a+1;

    if l=5 then if y mod 2=0 then s:=s+1 else a:=a+1;

    if l=6 then if u mod 2=0 then s:=s+1 else a:=a+1;

    if l=7 then if i mod 2=0 then s:=s+1 else a:=a+1;

    if l=8 then if o mod 2=0 then s:=s+1 else a:=a+1;

    if l=9 then if p mod 2=0 then s:=s+1 else a:=a+1;

    end;

    writeln ('Чётных: ', s) ;

    writeln ('Нечётных: ', a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая последовательно запросит 10 целых чисел и в результате сообщит, сколько среди введенных чисел четных и сколько ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу по которой компьютер десять раз запросит ввод целых и в результате сообщит сколько среди введённых чисел чётных и сколько нечётных. Паскаль, соответственно.
Ответы (1)
Составить блок схему и программу по которой комп 10 раз запросит ввод целых чисел и сообщит сколько четных и нечётных (прогу в паскале)
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Составьте программу, по которой компьютер 10 раз запросит ввод целого числа и в результате сообщит, сколько среди них оканчивается нулём, а сколько пятью (в Паскале). Как можно скорее!
Ответы (1)
Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел (массив не использовать). Сделайте три варианта программы, используя операторы While, Repeat, For.
Ответы (1)