Задать вопрос
5 августа, 04:10

Написать программу на Паскале, которая формирует случайным образом массив из n - целых чисел, лежащих в диапозоне от 1 до 5, вывести сма массив и номера элементов совпадающих с первым элементом.

+2
Ответы (1)
  1. 5 августа, 06:41
    0
    program zadanie;

    var

    a: array[1 ... 99999] of real;

    i, n: integer;

    begin

    randomize;

    write ('Введите число чисел массива: ') ; readln (n) ;

    for i:=1 to n do

    begin

    a[i]:=1+random (5) ;

    writeln ('a[', i, ']=', a[i]) ;

    end;

    write ('Номера элементов, совпадающих с первым элементом: ') ;

    for i:=1 to n do if a[i+1]=a[1] then write (i+1:3) ;

    writeln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на Паскале, которая формирует случайным образом массив из n - целых чисел, лежащих в диапозоне от 1 до 5, вывести сма ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу, которая формирует случайным образом массив из N целых чисел, лежащих в диапазоне от 1 до 5, после чего на экран выводится сам массив и номера элементов, совпадающих с первым элементом
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Заполнить одномерный массив целых чисел из 12 элементов случайным образом. Вывести его на экран. В следующей строке вывести элементы массива, имеющие порядковые номера 2,3,4,9,12. В следующей строке вывести максимальный элемент массива.
Ответы (2)