Задать вопрос
22 августа, 20:46

Заполнить одномерный массив целых чисел из 12

элементов случайным образом. Вывести его на экран. В следующей строке вывести

элементы массива, имеющие порядковые номера 2,3,4,9,12. В следующей строке

вывести максимальный элемент массива.

+3
Ответы (2)
  1. 22 августа, 22:19
    0
    Uses crt;

    const N=12;

    var mas: array [1 ... N] of integer;

    x, max: integer;

    begin

    randomize;

    for x:=1 to N do

    begin

    mas[x]:=random (99) + 1;

    writeln ('mas[', x,']:', mas[x]) ;

    end;

    max:=mas[1];

    for x:=1 to N do

    if mas[x]>max then max:=mas[x];

    writeln;

    writeln (mas[2],' ', mas[3],' ', mas[4],' ', mas[9],' ', mas[12]) ;

    writeln ('max=', max) ;

    readln;

    end.
  2. 23 августа, 00:08
    0
    Program gt;

    var a:array[1 ... 12]of integer;

    n, i, max:integer;

    begin

    randomize;

    for i:=1 to 12 do

    begin

    a[i]:=random (100) - 50;

    write (a[i],' ') ;

    end;

    writeln;

    write (a[2],' ', a[3],' ', a[4],' ', a[9],' ', a[12],' ') ;

    max:=a[1];

    for i:=2 to 12 do

    begin

    if (a[i]>max) then max:=a[i];

    end;

    writeln (max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Заполнить одномерный массив целых чисел из 12 элементов случайным образом. Вывести его на экран. В следующей строке вывести элементы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. заполните одномерный массив B1 размерностью в N (< 30 задает пользователь при выполнении программы) элементов так, чтобы каждый элемент с четным номером был равен половине своего номера, а каждый элемент с нечетным номером - количеству элементов
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (2)