Задать вопрос
10 апреля, 11:04

Написать программу, которая формирует случайным образом массив из N целых чисел, лежащих в диапазоне от 1 до 5, после чего на экран выводится сам массив и номера элементов, совпадающих с первым элементом

+3
Ответы (1)
  1. 10 апреля, 13:11
    0
    const

    N = 5;

    var

    a: array [1 ... N] of integer;

    i: integer;

    begin

    for i: = 1 to N do

    a[i]: = random (5) + 1;

    writeln ('Сформированный массив:') ;

    for i: = 1 to N do

    writeln (a[i]) ;

    writeln ('Номера элементов, совпадающих с первым элементом:') ;

    for i: = 2 to N do

    if a[i] = a[1] then writeln (i) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая формирует случайным образом массив из N целых чисел, лежащих в диапазоне от 1 до 5, после чего на экран ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу на Паскале, которая формирует случайным образом массив из n - целых чисел, лежащих в диапозоне от 1 до 5, вывести сма массив и номера элементов совпадающих с первым элементом.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
1. заполните одномерный массив B1 размерностью в N (< 30 задает пользователь при выполнении программы) элементов так, чтобы каждый элемент с четным номером был равен половине своего номера, а каждый элемент с нечетным номером - количеству элементов
Ответы (1)