Задать вопрос
16 января, 22:03

Составьте программу нахождения трёхзначного числа, куб суммы цифр которого равен ему самому

+4
Ответы (1)
  1. 16 января, 22:16
    0
    var

    a, b, c, n:integer;

    begin

    for n:=100 to 999 do

    begin

    a: = n div 100;

    b: = n div 10 mod 10;

    c: = n mod 10;

    if (a+b+c) * (a+b+c) * (a+b+c) = n then writeln (n) ;

    end;

    end.

    и в результате получаем, что это число 512
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу нахождения трёхзначного числа, куб суммы цифр которого равен ему самому ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике