Задать вопрос
5 марта, 04:54

Написать программу нахождения суммы цифр трехзначного числа (для отрицательных и положительных чисел)

+3
Ответы (1)
  1. 5 марта, 06:03
    0
    Program zzadani;

    Var n, b, a, c:integer;

    Begin

    Writeln ('Введите трехзначное число') ;

    Readln (n) ;

    a:=n div 100;

    b: = (n div 10) mod 10;

    c: = (n mod 100) mod 10;

    n:=a+b+c;

    Writeln ('Сумма цифр данного числа=', n) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу нахождения суммы цифр трехзначного числа (для отрицательных и положительных чисел) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
1. Составить программу для нахождения площади трапеции. 2. Составить программу для нахождения квадрата суммы двух чисел (по формулам сокращённого умножения). 3.
Ответы (1)
Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел.
Ответы (1)
Напишите программу на Паскале. Дан массив положительных и отрицательных чисел. Вычислить сумму положительных и произведение отрицательных чисел. А[1 ... 10]
Ответы (1)
Pascal. Требуется помощь. Составьте программу вычисления суммы цифр введённого с клавиатуры трёхзначного натурального числа. Например, для числа 128 сумма цифр 11, для числа 345 сумма цифр 12.
Ответы (1)