Задать вопрос
6 июня, 07:56

Вводить числа в переменную х. пока не будет введён 0. На печать ввыдать сумму введённых чисел и сами числа

+2
Ответы (1)
  1. 6 июня, 11:46
    0
    label nach;

    uses crt;

    var x, s:integer;

    begin

    s:=0;

    repeat

    nach:

    write ('vvedite x=') ; read (x) ;

    if (x!=0) then begin writeln (x) ; s:=s+x; goto nach; end else s:=s+x;

    until (x=0) ;

    writeln ('summa ravna=', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вводить числа в переменную х. пока не будет введён 0. На печать ввыдать сумму введённых чисел и сами числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Язык Паскаль! 1) Вводить с клавиатуры числа, пока не будут введен 0. Найти количество введенных чисел. 2) Числа задаются случайно в диапазоне от [-10,10] и выводятся на экран. Находится сумма числе, пока число не станет равным 0.
Ответы (1)
Написать программу в Pascal Даны число A>0, числа x1, x2 ... Необходимо вводить числа x1, x2 ..., пока сумма модулей введенных чисел будет меньше A. Определить число введенных чисел. P.
Ответы (1)
в паскале Ввести два числа K и N. Вводить последовательно числа, используя переменную R, пока R не будет равен K или N. На печать выдать сумму положительных чисел R.
Ответы (1)
Вводить с клавиатуры числа, пока не будут введен 0. Найти количество введенных чисел.
Ответы (1)
Составить две программы на языке Паскаля с помощью операторов цикла До и Пока, которые будут вводить целые числа (до тех пор, пока не будет введен ноль), подсчитывать сумму и среднее арифметическое введеных положительных чисел.
Ответы (1)