Задать вопрос
6 июня, 08:02

Дан целочисленный массив из N элементов, заданный датчиком случайных чисел в интервале (-55,99). Сформировать новый массив, из значений элементов данного массива больших 51 и имеющих индексы кратные 3

+5
Ответы (1)
  1. 6 июня, 10:18
    0
    Const

    n = 20;

    var

    a: array[1 ... n] of integer;

    b: array[1 ... (n div 3) + 1] of integer;

    i, m: integer;

    begin

    Randomize;

    Writeln ('Элементы массива') ;

    m : = 0;

    for i : = 1 to n do

    begin

    a[i]: = Random (155) - 55;

    Write (a[i]:4) ;

    if (a[i]>51) and (i mod 3=0) then

    begin m:=m+1; b[m]:=a[i] end

    end;

    Writeln;

    if m>0 then begin

    Writeln ('Элементы сформированного массива') ;

    for i : = 1 to m do Write (b[i]:3) ;

    Writeln

    end

    else Writeln ('Нет элементов с индексом, кратным 3, больших 51')

    end.

    Тестовое решение:

    Элементы массива

    57 - 3 79 - 49 30 87 - 15 49 - 38 - 49 - 45 - 38 55 - 27 48 - 29 56 63 79 - 2

    Элементы сформированного массива

    79 87 63
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан целочисленный массив из N элементов, заданный датчиком случайных чисел в интервале (-55,99). Сформировать новый массив, из значений ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Заполнить массив А (13) датчиком случайных чисел в интервале от 0 до 40 определить количество элементов массива не превосходящих по величине число В число В задается датчиком случайных чисел в интервале от 0 до 20
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)