Задать вопрос
1 февраля, 17:58

Составить две программы на языке Паскаля с помощью операторов цикла До и Пока, которые будут вводить целые числа (до тех пор, пока не будет введен ноль), подсчитывать сумму и среднее арифметическое введеных положительных чисел.

+1
Ответы (1)
  1. 1 февраля, 19:54
    0
    Program N1;

    Uses Crt;

    var n, s, c:real;

    begin

    clrscr;

    write ('Введите числа. Конец ввода 0: ') ;

    n:=1; s:=0; c:=0;

    while (n0) do

    begin

    readln (n) ;

    if (n=0) then break;

    if (n>0) then

    begin

    s:=s+n;

    c:=c+1;

    end;

    end;

    writeln ('Сумма чисел:', s) ;

    writeln ('Среднее арифметическое:', s/c) ;

    readkey;

    end.

    Program N2;

    Uses Crt;

    var n, s, c:real;

    begin

    clrscr;

    write ('Введите числа. Конец ввода 0: ') ;

    s:=0; c:=0;

    repeat

    readln (n) ;

    if (n=0) then break;

    if (n>0) then

    begin

    s:=s+n;

    c:=c+1;

    end;

    until (c=0) ;

    writeln ('Сумма чисел:', s) ;

    writeln ('Среднее арифметическое:', s/c) ;

    readkey;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить две программы на языке Паскаля с помощью операторов цикла До и Пока, которые будут вводить целые числа (до тех пор, пока не будет ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и определение максимального (наибольшего) из введёных чисел. Используйте оператор repeat. Решить в паскале.
Ответы (1)
Осуществить ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён 0) и подсчитать их сумму и среднее арифметическое введённых положительных чисел. Использовать оператор repeat.
Ответы (1)
Сколько раз будет выполнено тело цикла? А. for i:=-5to5 do тело цикла; В. for i:=6 to 2 do тело цикла; С. for i: = 3to 3 do тло цикла; D. for i:=3 downto 4 do тело цикла E. for i : = 3 downto 1 do тело цикла
Ответы (1)
Программу которая будет вводить целые числа до тех пор пока не будет введен нуль и определение
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчитать количество введённых положительных и отрицательных чисел.
Ответы (1)