Задать вопрос
20 ноября, 17:39

2) Дан целочисленный массив из 20 элементов, все элементы которого - целые числа в интервале от - 1000 до 1000. Опишите на русском языке или на одном из языков программирования алгоритм, который находит минимальное значение из всех нечетных элементов массива, которые делятся на 5.

+2
Ответы (2)
  1. 20 ноября, 18:55
    0
    var

    a:array [1 ... 100] of integer;

    n, k, i, j:integer;

    begin

    {вводим}

    for i:=1 to 20 do {элементы}

    read (a[i]) ; {массива}

    for j:=1 to N-1 do {сортируем элементы массива по возрастанию,}

    for i:=1 to N-j do

    if a[i] > a[i+1]

    then

    begin

    k:=a[i];

    a[i]:=a[i+1];

    a[i+1]:=k;

    end; {то есть от самого маленького до самого большого}

    for i:=1 to 20 do {выполняем заданное условие}

    if ((a[i] mod 2) = 1) and ((a[i] mod 5) = 0)

    then

    begin

    writeln ('Требуемое значение ', a[i]) ;

    break;

    end;

    end.
    1. 20 ноября, 18:14
      0
      А можете перевести на c++ (массив) плииз
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «2) Дан целочисленный массив из 20 элементов, все элементы которого - целые числа в интервале от - 1000 до 1000. Опишите на русском языке ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Дан целочисленный массив из 10 элементов все элементы которого целые числа в интервале от - 1000 до 1000. напишите программу которая находит количество элементов всех нечетных элементов массива которые делятся на 3 на языке Pascal желательно
Ответы (2)
Дан вещественный массив из 40 элементов. Элементы массива могут принимать произвольные значения. Опишите на русском языке или на одном из языков программирования алгоритм, который находит и выводит минимальный положительный элемент массива или
Ответы (1)
Дан целочисленный массив из 20 элементов, все элементы которого - целые числа в интервале от - 1000 до 1000.
Ответы (1)
дан целочисленный массив из 40 элементов, все элементы которого-целые числа в интервале от - 500 до 500.
Ответы (1)