Задать вопрос
15 августа, 18:12

Дан целочисленный массив из 20 элементов, все элементы которого - целые числа в интервале от - 1000 до 1000. Опишите на языке программирования паскаль алгоритм, который находит минимальное значение из всех нечетных элементов массива, которые делятся на 5. Если таких чисел нет, нужно вывести сообщение "таких чисел нет"

+5
Ответы (1)
  1. 15 августа, 18:19
    0
    Var

    a:array [1 ... 100] of integer;

    n, l, i, j:integer;

    begin

    for i:=1 to 20 do

    read (a[i]) ;

    for j:=1 to N-1 do

    for i:=1 to N-j do

    if a[i] > a[i+1]

    then

    begin

    l:=a[i];

    a[i]:=a[i+1];

    a[i+1]:=l;

    end;

    for i:=1 to 20 do

    if ((a[i] mod 2) = 1) and ((a[i] mod 5) = 0)

    then

    begin

    writeln (a[i]) ;

    break;

    else writeln ('таких чисел нет') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан целочисленный массив из 20 элементов, все элементы которого - целые числа в интервале от - 1000 до 1000. Опишите на языке ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Дан целочисленный массив из 10 элементов все элементы которого целые числа в интервале от - 1000 до 1000. напишите программу которая находит количество элементов всех нечетных элементов массива которые делятся на 3 на языке Pascal желательно
Ответы (2)
2) Дан целочисленный массив из 20 элементов, все элементы которого - целые числа в интервале от - 1000 до 1000.
Ответы (2)
Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от - 1000 до 1000 включительно. Опишите алгоритм, позволяющий найти и вывести минимальное значение среди отрицательных элементов массива, оканчивающихся на 3.
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)