Задать вопрос
4 марта, 10:33

1) Дан массив из 10 чисел. Найти произведение положительных чисел. 2) Дан массив из 10 чисел. Найти сумму отрицательных.

+4
Ответы (1)
  1. 4 марта, 13:06
    0
    Program t1;

    Var A: array [1 ... 10] of Integer; i: Byte; s: Longint;

    Begin

    s:=1;

    For i: = 1 to 10 do

    Begin

    Readln (A[i]) ;

    If A[i]>0 then

    s:=s*A[i];

    End;

    Write (s) ;

    Readln;

    End.

    Для отрицательных чисел замени A[i]>0 на A[i]<0, s:=s*A[i] на s:=s+A[i] и s:=1 убери
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Дан массив из 10 чисел. Найти произведение положительных чисел. 2) Дан массив из 10 чисел. Найти сумму отрицательных. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
Напишите программу на Паскале. Дан массив положительных и отрицательных чисел. Вычислить сумму положительных и произведение отрицательных чисел. А[1 ... 10]
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Дан массив MAS вещественного типа, содержащий 20 положительных и отрицательных элементов. Сформировать массив С из положительных элементов массива MAS, имеющих четный индекс. Найти сумму квадратов элементов нового массива.
Ответы (1)