Задать вопрос
30 ноября, 05:11

1) задан массив из N элементов. вычислить среднее арифметическое тех элементов, которые кратны 3. 2) Задан массив из N элементов. Сформировать новый массив из элементов, кратных 7.

+3
Ответы (1)
  1. 30 ноября, 05:31
    0
    За 2 программы мог бы и побольше пкт накинуть ...

    1)

    Program 1z;

    Var A: array [1 ... 100] of Integer; N, i: Byte; sa, t: Real;

    Begin

    Readln (N) ;

    For i: = 1 to N do

    Begin

    Readln (A[i]) ;

    If A[i] mod 3 = 0 then

    Begin

    sa:=sa+A[i];

    t:=t+1;

    End;

    End;

    sa:=sa/k;

    Writeln (sa) ;

    Readln;

    End.

    2)

    Program 2z;

    Var A, B: array [1 ... 100] of Integer; i, s, N: Byte;

    Begin

    Readln (N) ;

    For i:=1 to N do

    Begin

    Readln (A[i]) ;

    If A[i] mod 7 = 0 then

    Begin

    s:=s+1;

    B[s]:=A[i];

    Writeln (B[s]) ;

    End;

    End;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) задан массив из N элементов. вычислить среднее арифметическое тех элементов, которые кратны 3. 2) Задан массив из N элементов. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2) Задан массив из 11 целых чисел. Посчитать количество нечётных элементов массива. 3) задан массив из 9 целых чисел. Вывести на экран чётные элементы
Ответы (1)
Напишите программу с помощью Паскаля. Сформировать массив случайным образом (длина массива 20). Найти в нем среднее арифметическое. Сформировать новый массив из элементов первого больших среднего арифметического.
Ответы (2)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)
Составить программу (Паскаль) Сформировать массив (t кол-во элементов 20) случайных чисел, выбранных на интервале от - 10 до + 10. Вывести кол-во нулевых элементов, сумму элементов кратных 3 и среднее арифметическое всех элементов массива.
Ответы (1)