Задать вопрос
9 февраля, 16:04

Напишите программу с помощью Паскаля.

Сформировать массив случайным образом (длина массива 20). Найти в нем среднее арифметическое. Сформировать новый массив из элементов первого больших среднего арифметического.

+3
Ответы (2)
  1. 9 февраля, 17:24
    0
    Программа формирует новый массив со смещением в лево

    Program sector;

    const

    n=10;

    var

    a, b:array [1 ... n, 1 ... n] of integer;

    z:real;

    i, j, k: byte;

    begin

    randomize;

    for i:=1 to n do begin

    for j:=1 to n do begin

    a[i, j]:=random (40) ;

    a[i, j]:=a[i, j]-20;

    write (a[i, j]:4) ;

    end;

    writeln;

    end;

    z:=0;

    for i:=1 to n do

    for j:=1 to i do

    z:=z+a[i, j];

    z:=z / (n*n) ;

    writeln ('srednee = ', z) ;

    for i:=1 to n do begin

    k:=1;

    for j:=1 to n do

    if a[i, j] > z then begin

    b[i, k]:=a[i, j];

    write (b[i, k]:4) ;

    k:=k+1;

    end;

    writeln;

    end;

    readln;

    end.
  2. 9 февраля, 19:58
    0
    Begin

    var i, j: integer;

    var s: real;

    var m: array[1 ... 20] of integer;

    var n: array[1 ... 20] of integer;

    { формируем массив и заодно вычисляем сумму элементов }

    for i : = 1 to 20 do begin

    m[i] : = random (1000) ;

    s : = s + m[i];

    end;

    { печать массива }

    for i : = 1 to 20 do begin

    writeln (m[i]) ;

    end;

    writeln ('') ;

    { среднее арифметическое }

    s : = s / 20;

    writeln (s) ;

    j : = 0;

    for i : = 1 to 20 do begin

    if m[i] > s then begin

    j : = j + 1;

    n[j] : = m[i];

    end;

    end;

    writeln ('') ;

    for i : = 1 to j do begin

    writeln (n[i]) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу с помощью Паскаля. Сформировать массив случайным образом (длина массива 20). Найти в нем среднее арифметическое. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Массив заполнен случайным образом 20 числами в интервале от 0 до 100. 1) найти максимальный и минимальный элемент массива, а так же их сумму 2) найти среднее арифметическое элементов массива 3) из элементов массива сформировать два массива с четными
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Сформировать одномерный массив из N элементов (значения элементов задаются случайным образом в диапазоне от - 20 до 80). Вывести массива на экран.
Ответы (1)