Задать вопрос
7 июля, 01:38

1) Дан одномерный массив из 12 элементов. Составить программу заполняющую массив целыми числами в интервале - 20 до 15

2) Требуется подсчитать кол-во пятерок, четверок, тоек полученных за контрольную работу, если число учеников равно 8

3) Дан одномерный числовой массив, изменить знак элементов массива К[1; 12] на противоположный

+3
Ответы (1)
  1. 7 июля, 05:12
    0
    var

    a:array[1 ... 12] of integer;

    i:integer;

    begin

    randomize;

    writeln ('Сгенерированный массив:') ;

    for i : = 1 to 12 do

    begin

    a[i] : = random (36) - 15;

    write (a[i], ' ') ;

    end;

    writeln;

    end.

    //вторая программа

    const

    n = 8;

    var

    a:array[1 ... n] of integer;

    i, count3, count4, count5:integer;

    begin

    randomize;

    writeln ('Оценки учеников:') ;

    for i : = 1 to n do

    begin

    a[i] : = random (3) + 3;

    write (a[i], ' ') ;

    if a[i] = 5 then

    inc (count5) ;

    if a[i] = 4 then

    inc (count4) ;

    if a[i] = 3 then

    inc (count3) ;

    end;

    writeln;

    writeln ('Троек - ', count3) ;

    writeln ('Четверок - ', count4) ;

    writeln ('Пятерок - ', count5) ;

    end.

    //третья программа

    var

    k:array[1 ... 12] of integer;

    i:integer;

    begin

    randomize;

    writeln ('Сгенерированный массив:') ;

    for i : = 1 to 12 do

    begin

    k[i] : = random (36) - 15;

    write (k[i], ' ') ;

    end;

    writeln;

    writeln ('Преобразованный массив:') ;

    for i : = 1 to 12 do

    begin

    k[i] : = k[i] * (-1) ;

    write (k[i], ' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Дан одномерный массив из 12 элементов. Составить программу заполняющую массив целыми числами в интервале - 20 до 15 2) Требуется ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Написать программу в Паскале. Указания: Заполните одномерный числовой массив А[15] случайными целыми числами в интервале [18; 15]. Выведите значения элементов массива сначала в столбик, а затем в строку, причем на каждый элемент отведите 4 позиции.
Ответы (1)