Задать вопрос
2 августа, 16:07

Написать программу в Паскале.

Указания: Заполните одномерный числовой массив А[15] случайными целыми числами в интервале [18; 15]. Выведите значения элементов массива сначала в столбик, а затем в строку, причем на каждый элемент отведите 4 позиции.

Задача: Заменить элементы массива, которые кратны пяти, на значение максимального элемента массива.

+3
Ответы (1)
  1. 2 августа, 17:22
    0
    Const n=15;

    var

    a:array[1 ... n]of integer;

    i, i_max:integer;

    begin

    for i:=1 to n do

    begin

    a[i]:=random (4) + 15;

    writeln (a[i]) ;

    end;

    writeln;

    for i:=1 to n do

    write (a[i]:4) ;

    writeln;

    i_max:=1;

    for i:=2 to n do

    if a[i]>a[i_max]then

    i_max:=i;

    for i:=1 to n do

    if a[i]mod 5=0 then

    a[i]:=a[i_max];

    for i:=1 to n do

    write (a[i]:4) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в Паскале. Указания: Заполните одномерный числовой массив А[15] случайными целыми числами в интервале [18; 15]. Выведите ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С # 1. Создайте одномерный массив с 31 элементов, которые заполните случайными целыми числами от 11 до 100-11. Выведите значения элементов массива в строку, разделив их пробелами, 11 нечетное число.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
Написать программу в Паскале! Указание: Заполнить двумерный числовой массив И (8,8) случайными целыми числами в интервале [-60,60]. Написать единую программу для всех задач, ответ каждой задачи выводить с новой строки.
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)