Задать вопрос
30 марта, 23:55

Напишите в виде программы для паскаля.

В массиве А (5) посчитать количество положительных и отрицательных элементов

+3
Ответы (1)
  1. 31 марта, 03:20
    0
    var

    a: array[1 ... 5] of integer;

    p, ot, i:integer;

    begin

    p:=0;

    ot:=0;

    for i:=1 to 5 do

    readln (a[i]) ;

    for i:=1 to 5 do begin

    if a[i]>0 then

    p:=p+1

    else

    ot:=ot+1;

    end;

    writeln ('polozitelnich=', p, ' otrizatelnich=', ot) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите в виде программы для паскаля. В массиве А (5) посчитать количество положительных и отрицательных элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программы для паскаля для следующих задач: 1. В массиве из 10 элементов подсчитать количество нечетных элементов 2. Вычислить сумму квадратов элементов, больших 2. Массив состоит из 5 элементов действительного типа. 3. Даны два массива.
Ответы (1)
В заданном массиве А (m, n) найти количество положительных элементов по столбцам. Образовать массив B (m, n), делением элементов заданного массива на найденное количество положительных элементов по столбцам.
Ответы (1)
Напишите программу вычисления разности максимального среди элементов, имеющих чётные значения, и максимального среди элементов, имеющих нечётные значения, в заданном целочисленном массиве из 10 положительных элементов (в предположении, что в массиве
Ответы (1)
Написать программу Заполнить массив из 15 элементов случайными числами (-20; 80) Посчитать сумму всех элементов массива Посчитать количество отрицательных элементов
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)