Задать вопрос
17 июня, 10:19

В заданном массиве А (m, n) найти количество положительных элементов по столбцам. Образовать массив B (m, n), делением элементов заданного массива на найденное количество положительных элементов по столбцам.

+5
Ответы (1)
  1. 17 июня, 11:01
    0
    Program gt;

    var a:array[1 ... 100,1 ... 100]of longint;

    k, m, i, n, j:longint;

    b:array[1 ... 100,1 ... 100]of real;

    begin

    read (n, m) ;

    for i:=1 to n do

    begin

    for j:=1 to m do

    begin

    read (a[i, j]) ;

    end;

    end;

    for j:=1 to m do

    begin

    k:=0;

    for i:=1 to n do

    begin

    if (a[i, j]>0) then k:=k+1;

    end;

    for i:=1 to n do

    begin

    b[i, j]:=a[i, j]/k;

    end;

    end;

    for i:=1 to n do

    begin

    for j:=1 to m do

    begin

    write (b[i, j],' ') ;

    end;

    writeln;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В заданном массиве А (m, n) найти количество положительных элементов по столбцам. Образовать массив B (m, n), делением элементов заданного ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)