Задать вопрос
28 февраля, 16:14

Составить программы для паскаля для следующих задач:

1. В массиве из 10 элементов подсчитать количество нечетных элементов

2. Вычислить сумму квадратов элементов, больших 2. Массив состоит из 5 элементов действительного типа.

3. Даны два массива. Сформировать третий массив, каждый элемент которого равен разности соответствующих элементов известных массивов.

4. Определить значение и порядковых номер максимального элемента.

+2
Ответы (1)
  1. 28 февраля, 19:52
    0
    Program z1;

    uses crt;

    const n=10;

    var a: array[1 ... n] of integer;

    i, s: integer;

    begin

    clrscr;

    s:=0;

    writeln ('Введите элементы массива') ;

    for i:=1 to n do begin

    read (a[i]) ; / / ввод элементов в одну строку через пробел

    if a[i] mod 2 = 1 then inc (s)

    end;

    writeln (s) ;

    readkey;

    end.

    program z2;

    uses crt;

    const n=5;

    var a: array[1 ... n] of real;

    i: integer;

    s: real;

    begin

    clrscr;

    s:=0;

    writeln ('Введите элементы массива') ;

    for i:=1 to n do begin

    read (a[i]) ; / / ввод элементов в одну строку через пробел

    if a[i]>2 then s:=s+sqr (a[i])

    end;

    writeln (s) ;

    readkey;

    end.

    program z3;

    uses crt;

    const n=5;

    var a1, a2, a3: array[1 ... n] of integer;

    i: integer;

    begin

    clrscr;

    randomize;

    for i:=1 to n do begin

    a1[i]: = random (100) + 1; / / рандомное число от 1 до 100

    a2[i]: = random (100) + 1;

    a3[i]:=a1[i]-a2[i];

    writeln (a1[i], ' ', a2[i], ' ', a3[i]) ;

    end;

    readkey;

    end.

    program z4;

    uses crt;

    const n=10;

    var a: array[1 ... n] of integer;

    max, c, i: integer;

    begin

    clrscr;

    writeln ('Введите элементы массива') ;

    for i:=1 to n do read (a[i]) ;

    max:=a[i];

    for i:=1 to n do begin

    if max
    end

    end;

    writeln ('') ;

    writeln ('max=', max, ' номер=', c) ;

    readkey;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программы для паскаля для следующих задач: 1. В массиве из 10 элементов подсчитать количество нечетных элементов 2. Вычислить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
Заполнить два массива (из 10 элементов каждый) случайными числами. Сформировать третий массив, каждый элемент которого равен полусумме соответствующих элементов исходных массивов.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. сформируйте массив содержащий 10 элементов с помощью датчика случайных чисел получить новый массив, каждый элемент которого равен сумме соответствующего элемента и его номера исходного массива. 2.
Ответы (1)