Задать вопрос
8 октября, 07:00

1. Написать программу, которая вычисляет произведение цифр к-значного числа.

2. пусть элементами равносторон. треугольника являются: сторона a, высота h, площадь S, вписанная окружность r, описанная окружность R. составить программу, которая по заданному номеру и значению элемента, вычисляла бы значения всех остальных элементов

+5
Ответы (1)
  1. 8 октября, 08:21
    0
    Решу только первую задачу.

    const k=?; {Вместо "?" подставить любое значение k}

    Var x, i, s:integer;

    Begin

    write ('x=') ;

    readln (x) ;

    s:=1;

    for i:=1 to k do

    begin

    s:=s * (x mod 10) ;

    x:=x div 10;

    end;

    writeln ('s=', s) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Написать программу, которая вычисляет произведение цифр к-значного числа. 2. пусть элементами равносторон. треугольника являются: ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Пусть элементами круга являются радиус (первый элемент), диаметр (второй элемент) и длина окружности (третий элемент). Составить программу, которая по номеру элемента запрашивала бы его соответствующее значение и вычисляла бы площадь круга.
Ответы (1)
Написать программу в Паскаль: 1) Составьте программу, которая по заданному году и номеру месяца определит кол-во дней в этом месяце. 2) Для любого 2-ух значного числа, вывести его значение в словесной форме.
Ответы (1)
Составить программу, которая по введенному номеру и величине радиуса вычисляла: 1 - длину окружности, 2 - площадь круга, 3 - объем шара.
Ответы (1)
1. Определите, сколько элементов массива A равны заданному значению X. 2. Вычислить произведение всех элементов массива A, которые делятся на 3. 3. Определите в массиве A номер первого элемента, равного X.
Ответы (1)
2. Составить программу, которая вычисляет количество чисел кратных 3, 4 и 5 одновременно в диапазоне от 1 до 1000. 3. Составить программу, которая вычисляет факториал числа 7!
Ответы (1)