Задать вопрос
8 марта, 03:59

Составить программу, которая по введенному номеру и величине радиуса вычисляла: 1 - длину окружности, 2 - площадь круга, 3 - объем шара.

+1
Ответы (1)
  1. 8 марта, 07:16
    0
    Const

    Pi=3.1416;

    var

    n:integer;

    r:real;

    begin

    Write ('Укажите вариант расчета и радиус: ') ;

    Read (n, r) ;

    case n of

    1:Writeln ('Длина окружности равна ',2*Pi*r) ;

    2:Writeln ('Пдощадь круга равна ', Pi*r*r) ;

    3:Writeln ('Объем шара равен ',4/3*Pi*r*r*r)

    else Writeln ('Вариант должет быть равен 1,2 или 3')

    end

    end.

    Пример

    Укажите вариант расчета и радиус: 3 11.7

    Объем шара равен 6708.8365344
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая по введенному номеру и величине радиуса вычисляла: 1 - длину окружности, 2 - площадь круга, 3 - объем шара. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы