Задать вопрос
5 июня, 08:04

1. Определите, сколько элементов массива A равны заданному значению X.

2. Вычислить произведение всех элементов массива A, которые делятся

на 3.

3. Определите в массиве A номер первого элемента, равного X.

+1
Ответы (1)
  1. 5 июня, 10:38
    0
    Const

    K = 13;

    Var

    A:array[1 ... K] of integer;

    i, n, X:integer;

    Begin

    Write ('X = ') ; ReadLn (X) ;

    Write ('Исходный массив: ') ;

    For i: = 1 to K do

    Begin

    A[i]:=random (21) - 10;

    Write (A[i],' ') ;

    End;

    n:=0;

    For i: = 1 to K do

    if A[i]=X then n:=n+1;

    WriteLn;

    WriteLn (n,' - кол-во элементов, равных ', X) ;

    End.

    Const

    K = 13;

    Var

    A:array[1 ... K] of integer;

    i:integer;

    P:real;

    Begin

    P:=1;

    Write ('Исходный массив: ') ;

    For i: = 1 to K do

    Begin

    A[i]:=random (21) - 10;

    Write (A[i],' ') ;

    if A[i] mod 3 = 0 then P:=P*A[i]

    End;

    WriteLn;

    WriteLn ('Произведение элементов, кратных трём: ', P)

    End.

    Const

    K = 13;

    Var

    A:array[1 ... K] of integer;

    i, X:integer;

    Begin

    Write ('X = ') ; ReadLn (X) ;

    Write ('А: ') ;

    For i: = 1 to K do

    Begin

    A[i]:=random (21) - 10;

    Write (A[i],' ') ;

    End;

    WriteLn;

    i:=0;

    Repeat

    i:=i+1;

    Until (A[i]=X) or (i=K) ;

    if A[i]=X then WriteLn (i)

    else WriteLn ('Таких элементов нет')

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Определите, сколько элементов массива A равны заданному значению X. 2. Вычислить произведение всех элементов массива A, которые делятся ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Что определяет для массива X[1 ... n] следующий алгоритм R: = n; For k: = 1 to n do If X[k]
Ответы (1)
На Паскаль 1. С клавиатуры вводится число. Осуществить линейный поиск элемента в массиве. Вывести номер элемента, равного данному, либо сообщение о том, что такого элемента в массиве нет. 2.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)