Задать вопрос
23 ноября, 22:41

в массиве А (N) поменяйте местами первый отрицательный и минимальный элементы

+3
Ответы (1)
  1. 24 ноября, 01:13
    0
    uses crt;

    const N=10;

    var a:array[1 ... N] of integer;

    i, k, m, min, imin:integer;

    Begin

    readln (m) ;

    for i:=1 to m do begin

    readln (a[i]) ;

    min:=min+a[i];

    end;

    for i:=1 to m do begin

    if a[i]<0 then begin

    k:=i;

    break;

    end;

    end;

    for i:=1 to m do begin

    if a[i]
    min:=a[i];

    imin:=i;

    end;

    end;

    min:=a[imin];

    a[imin]:=a[k];

    a[k]:=min;

    for i:=1 to m do write (a[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «в массиве А (N) поменяйте местами первый отрицательный и минимальный элементы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
В одномерном массиве поменять местами минимальный и максимальный элементы. Все элементы большие 4 заменить числом 4. Посчитать количество таких элементов.
Ответы (1)
Дан массив целых чисел. Поменять местами первый максимальный (если таковых несколько) и последний минимальный (если таковых несколько) по значению элементы массива. Число элементов в массиве не более 10-ти Pascal
Ответы (1)
Python Напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Если хотя бы один элемент однородного массива отрицательный, то вывести сообщение элемент отрицательный, если иначе - все положительные.
Ответы (1)