Задать вопрос
24 ноября, 03:17

У скольких чисел от 1 до 2020 включительно ровно четыре натуральных делителя? (Включая 1 и само число).

+4
Ответы (1)
  1. 24 ноября, 05:52
    0
    Var n, k, i, j:integer;

    begin

    n:=0;

    for i:=2 to 2020 do

    begin

    k:=2;

    for j:=2 to i div 2 do

    if i mod j = 0 then k:=k+1;

    if k=4 then n:=n+1;

    end;

    writeln ('n = ', n) ;

    end.

    Результат:

    n = 571
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «У скольких чисел от 1 до 2020 включительно ровно четыре натуральных делителя? (Включая 1 и само число). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
У скольких чисел от 1 до 2030 включительно ровно четыре натуральных делителя? (Включая 1 и само число).
Ответы (1)
1) Запишите внутреннее представление десятичного числа - 104 в 8-разрядной ячейке памяти компьютера Ниже запишите ответ - только само число, без пояснений 2) Запишите внутреннее представление десятичного числа 79 в 8-разрядной ячейке памяти
Ответы (1)
Найдите наименьшее натуральное число, у которого ровно 32 делителя (включая 1 и само число 32). Например, у числа 6 четыре делителя: 1, 2, 3, 6. В качестве ответа укажите одно натуральное число.
Ответы (1)
Найдите наименьшее натуральное число, у которого ровно 36 делителей (включая 1 и само число 36). Например, у числа 6 четыре делителя: 1, 2, 3, 6. В качестве ответа укажите одно натуральное число.
Ответы (2)
Условие: Дано натуральное число. Проверить, является ли оно простым. Примечание: простым называется натуральное число, которое имеет ровно два различных натуральных делителя: единицу и само это число.
Ответы (2)