Задать вопрос
9 апреля, 14:07

Написать класс который принимает с клавиатуры целое число и выводит на экран три предыдущих ему целых числа причем каждое в отдельной строке

+2
Ответы (1)
  1. 9 апреля, 17:14
    0
    type Cl = class

    a:integer;

    constructor Create (b:integer) ;

    procedure SetVal (b:integer) ;

    function GetVal:integer;

    procedure GetPrev;

    end;

    constructor Cl. Create (b:integer) ;

    begin

    a : = b;

    end;

    procedure Cl. SetVal (b:integer) ;

    begin

    a : = b;

    end;

    function Cl. GetVal:integer;

    begin

    GetVal : = a;

    end;

    procedure Cl. GetPrev;

    var

    Pr, i:integer;

    begin

    writeln ('Три предыдущих') ;

    Pr : = Pred (a) ;

    for i : = 1 to 3 do

    begin

    writeln (Pr, ' ') ;

    Pr : = Pred (Pr)

    end;

    end;

    var

    Obj:Cl;

    begin

    Obj : = Cl. Create (5) ;

    Obj. GetPrev;

    writeln;

    Obj. Destroy;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать класс который принимает с клавиатуры целое число и выводит на экран три предыдущих ему целых числа причем каждое в отдельной строке ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу, которая вводит с клавиатуры 8 целых неотрицательных чисел (каждое число - с новой строки отдельной командой "ввод"), записывает их в массив, выводит на экран сначала в прямом порядке все без исключения элементы массива, затем, в
Ответы (1)
Написать программы на языке С++ 1) С клавиатуры вводится 2 числа - целое и вещественное. Программа выводит их сумму на экран.
Ответы (1)
Составьте задачу на Паскаль, используя диалог с пользователем. Компьютер выводит на экран: -Здравствуй, я компьютер, а тебя как зовут? Человек вводит с клавиатуры: -Коля Компьютер выводит на экран: -Очень приятно, Коля.
Ответы (1)
напишите класс который принимает с клавиатуры целое число и выводит на экран его квадрат но только в случае, если введенное число отрицательно. В противном случае на экран выводится сообщение ошибка
Ответы (2)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)