Задать вопрос
1 мая, 04:46

Cтроки. Паскаль.

1. Задано слово - последовательность произвольных символов. Сделать программу, в которой составляется слово перевертыш к данному (символы записываются в обратной последовательности.)

2. Дана символьная строка. Слово - последовательность символов между пробелами, не содержащая пробелы внутри себя. составить программу, в которой выводились бы все слова, в которых есть заданный символ.

+4
Ответы (1)
  1. 1 мая, 07:05
    0
    {Первая задача}

    var

    s, rez: string; / / строки

    i: integer; / / целое число (счетчик)

    begin

    writeln ('Введите строку:') ;

    readln (s) ; / /

    for i : = length (s) downto 1 do / / просматриваем буквы, начиная с последней

    rez : = rez + s[i]; / / прибавляем букву к результату

    writeln (rez) / / выводим результат

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Cтроки. Паскаль. 1. Задано слово - последовательность произвольных символов. Сделать программу, в которой составляется слово перевертыш к ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Дана строка, содержащая два слова, разделенные знаком нижнее подчеркивание. Написать программу заменяющую нижнее подчеркивание на запятую и вставляющую после запятой пробел. Дана строка, содержащая пробел.
Ответы (1)
Дана строка. Удвоить каждый символ строки, выбрать из нее символы кратные 4 и напечатать её наоборот. Поясняю, символы кратные 4-ем, это значит каждый 4-ый символ строки. "выбрать из нее символы кратные 4 и напечатать их (т. е.
Ответы (1)
Дана строка, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в ровно один раз. Формат входных данных Во входном файле дана строка.
Ответы (1)
Дана строка S, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в S ровно один раз. Формат входных данных Во входном файле дана строка S.
Ответы (1)