Задать вопрос
4 февраля, 16:05

Составить программу вычисления арифметической прогрессии числовой последовательности. Где кол-во элементов и сами элементы вводятся с клавиатуры?

+3
Ответы (1)
  1. 4 февраля, 18:29
    0
    var

    i, p, k, r, s:integer;

    mas: array[1 ... 100] of integer;

    begin

    s:=0;

    read (k) ;

    for i:=1 to k do

    read (mas[i]) ;

    r:=mas[2]-mas[1];

    for i:=1 to k do

    s:=s+mas[i];

    writeln ('raznost progressii=', r, ', summa elementov progressii=', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу вычисления арифметической прогрессии числовой последовательности. Где кол-во элементов и сами элементы вводятся с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вывести все значения элементов заданной числовой последовательности. Входные данные: Выходные данные: Во входном потоке в первой строке записано единственное целое число N (0 < N < = 100) - число элементов числовой последовательности;
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)