Задать вопрос
2 ноября, 23:42

Дан массив из 20 чисел. найти среднее арифметическое. найти наименьший элемент методом бинарного поиска. (Pascal)

+5
Ответы (1)
  1. 3 ноября, 00:15
    0
    var

    m : array [1 ... 20] of Integer;

    s : Real;

    i : Integer;

    begin

    s : = 0;

    for i : = 1 to 20 do

    s : = s + m[i];

    s : = s / 20;

    Writeln ('C реднее арифметическое = ', s:0:3) ;

    end.

    2.

    Насколько я знаю, для бинарного поиска нужно отсортировать массив, но если он отсортирован, то наименьший элемент будет 1. Может что-то путаю.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из 20 чисел. найти среднее арифметическое. найти наименьший элемент методом бинарного поиска. (Pascal) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Задачи на массив (паскаль) : Массив (подсчёт суммы) а) Дан массив целых чисел. Найти сумму нечётных элементов. б) Дан массив. Определить максимальный и минимальный элемент.
Ответы (1)