Задать вопрос
22 июня, 03:25

Дан массив из 10 элементов, которые заполняются случайным образом. Найти: а) наименьший элемент

б) сумму не положительных элементов

в) произведение элементов, кратных 3.

+2
Ответы (1)
  1. 22 июня, 03:35
    0
    я сделал рандомные числа от 0 до 100, если нужно можешь изменить, что бы заполнялся пользователем.

    a[10], i, min, s, p:integer

    randomize

    for i=1 to 10 do

    a[i]:=random (101) ;

    min:=a[i];

    s:=0

    p:=1

    for i=1 to 10 do begin

    if a[i]
    min:=a[i];

    if a[i]<0 then

    s:=s+a[i];

    if a[i] mod 3 = 0 then

    p:=p*a[i];

    end;

    write ('minimum=', min, ' summ=', s, ' umnosenie=', p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из 10 элементов, которые заполняются случайным образом. Найти: а) наименьший элемент б) сумму не положительных элементов в) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (2)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)